PHP Modul zum Einbinden einer Go-eCharger Wallbox

Ich beziehe mich mal auf diesen Punkt:

Wenn man sich das neue Log anschaut, dann sieht man eigentlich, wo das Problem liegt:

Wenn man 3phasig lädt, und dann das Laden beenden will, schaltet das Modul erst auf 1phasiges Laden um. Das hat zur Folge, das das Laden beendet und angestarrte wird (durch den GO-eCharger selbst). Dies hat dann wiederum zur Folge, das die Wartezeit neu greift, bis das das Modul das Laden umschaltet.

Um 18:08 wird das Ladeende angefordert, um 18:10 schaltet das Modul wg. der Wartezeit noch nicht ab, und um 18:11 wird dann das Laden deaktiviert.

Ich muss mal schauen, ob ich den Phasenwechsel beim Ziel „0W“ nicht übergehe (macht ja auch keinen Sinn). Das sollte das Problem dann minimieren.

Update: Beta 2.2.2 ist online. Bitte testen (kam noch nicht dazu)

Ok. Beta wird kommende Woche getestet.
Dann wäre event. Zwischenlösung bei Ziel 0W zusätzlich den Wallbox Modus bzw. „Wallbox aktiv“ zu schalten. Probiere das kommende Woche mal aus.

Hallo Coyote,

nach mehreren Ladevorgängen und heutigem Logging konnte ich den Test der Beta abschließen. Alles läuft wie gewünscht :smiley: :smiley:.
Vielen Dank!

Danke für die Rückmeldung. Version wurde als Stable eingereicht.

Ich habe bei einer go-e das Phänomen, dass ich sie zwar steuern kann, jedoch ausgerechnet den „aktuell verfügbaren Ladestrom“ kann ich nicht verändern. Der springt immer wieder auf den eingestellten Wert zurück.
Ein weiteres Phänomen ist dabei, wenn ich den maximal verfügbaren Ladestrom reduziere, dann reduziert es auch den aktuell verfügbaren Ladestrom auf diesen Wert. Wenn ich den maximalen Ladestrom allerdings dann wieder erhöhe, kann ich den verfügbaren Ladestrom nicht auch wieder erhöhen. Der bleibt dann auf dem reduzierten Wert stehen.

Welche Version der Box, welche Firmware Version? Wie sehen die Einstellungen im Modul aus? Funktioniert das Ändern des Ladestroms über die App?

Hallo, ich hab eine neue go-e v4 nach Ausfall einer v1 bekommen und bin natürlich sehr zufrieden mit dem Kulanztausch.
Mittlerweile funktioniert das Solarladen ausgezeichnet, aber das Strompreisladen klemmt.
Hat das mal einer mit der v4 (API2) realisiert?

Ich suche eine Möglichkeit die go-echarger Box von IPS aus zwischen den Lademodi „Eco“ und „Next Trip“ umzuschalten … hab da bisher noch nichts gefunden …geht das?

Gruß, Michael

Kenne die Funktion ehrlich gesagt gar nicht. In der API habe ich dazu („Modus ‚next Trip‘ aktivieren“) auch nichts gefunden.

Servus @mic ,
das geht über einen URL-Aufruf.
Umschalten auf ECO:

$handle = fopen(„http://192.168.11.91/api/set?frc=0“, „r“); //forceState (Neutral=0, Off=1, On=2)

$handle = fopen(„http://192.168.11.91/api/set?lmo=4“, „r“); // logic mode (Default=3, Awattar=4, AutomaticStop=5)

Umschalten auf „Next-Trip“:

$handle = fopen(„http://192.168.11.91/api/set?frc=1“, „r“); //forceState (Neutral=0, Off=1, On=2)

$handle = fopen(„http://192.168.11.91/api/set?lmo=5“, „r“); // logic mode (Default=3, Awattar=4, AutomaticStop=5)

(die IP musst du natürlich anpassen)
VG

Super, besten Dank ! Werde es demnächst probieren und berichten.
Gruß Michael

Hi, ich hab mal ne Frage zu der Datenübertragung per MQTT.

Das Modul läuft so weit einwandfrei, wenn ich es über den intervall aktivieren lasse. Wenn ich MQTT aktiviere werden einige Variablen auch zuverlässig aktualisiert aber andere überhaupt nicht. Für mich wichtig wäre an dieser Stelle eine Aktualisierung der aktuellen Ladeleistung. Am besten natürlich alle Variablen.
Kann man da noch mal was verbessern? (Hardware Rev. v4)

Gruß
Smudo

Habe auch eine Rev V4 - bei mir die aktuelle Ladeleistung angezeigt…

Über MQTT?
Alle 10 Sekunden (meine Einstellungen wenn aktiv) kommt ja bei mir auch die Ladeleistung, was dann aber leider für die bis zu 10 Sekunden dazu führt, das meine Visu Unsinn anzeigt.

Tja, jetzt sehe ich gerade, dass scheinbar jetzt (wo ich nicht lade) die Werte auch für die Aktuelle Ladeleistung aktualisiert werden. Schon merkwürdig, nach welchem Schema die Box hier Werte sendet. Z.B. die Werte für „Ladeende nach x kwh“ und „Ladeende nach Energie für x km“ werden sekündlich aktualisiert, obwohl sich die Werte nie ändern, ich die Funktion auch noch nie benutzt habe. Der Wert für die „Aktuelle Leistung zu Fahrzeug“ aktualisiert sich jetzt auch sekündlich allerding mit unregelmäßigen kurzen Aussetzern von wenigen Sekunden.
OK, werde ich jetzt auch nicht schlau draus. Auf jeden Fall schein ja dann Modulmäßig alles in in Ordnug zu sein, sonst hätte ich ja jetzt auch keine Daten. Dann liegts wohl an der Wallbox.

Gruß
Smudo

Beim MQTT habe ich mehrere Probleme. Im Grunde sendet das MQTT dieselben Abkürzungen mit Daten, wie auch die API (HTTP) Schnittstelle. Aber leider unterscheiden sich diese Daten über die API Versionen und Releases etwas. Ich habe auch nur 2 V3 Charger, kann also weder mit V1, V2 noch V4 oder gar neueren Gemini testen. Und die Schnittstellen-Stabilität von Go-E ist, sagen wir mal, Optimierungsbedürftig. Da habe ich schon so manche Überraschung erlegt.

Kurz: Ich selbst nutze MQTT eigentlich nicht und müsste dafür diverse Boxen testen können. Es würde vermutlich immer noch eine (mehr oder weniger große) Lücke entstehen. Deshalb empfehle ich klar die API zu nutzen.