[Modul] SML-Counter zur Integration der Infrarotschnittstelle von Haushaltszählern

V1.10 Fix: Profil „Watt“ für IPS-Version < 6.1

Für Nutzer alter IPS-Versionen gibt es jetzt einen Fix für das Variablenprofil. Damit wird auch ohne Update von IP-Symcon die Leistung (soweit vom Zähler gesendet) angezeigt.

Wie immer im Module-Store zunächst als Beta erhältlich.
Grüße
Jürgen

Das habe ich im Datenblatt gefunden vom Powerfox Poweropti:

Unterstützte Zähler und Protokolle:
 Kompatibel zu Zählern gemäß FNN-Lastenheft Basiszähler 1.4.1 (s. separate jeweils aktuelle Whitelist)
 Ausgabe der Daten in SML-Protokoll und IEC1107

das hört sich gut an. Und? Hast du es probiert?

Ja, habe es versucht zu installieren, aber scheitere schon am Port, weiß nicht was ich da auswählen muss. Ich denke das ich auch irgendwo mein Zugang hinterlegen muss vom PowerOpti um die Daten abzufragen.

Hi Jürgen,

eine Frage, was kann es bedeuten wenn von Zeit zu Zeit diese Fehlermeldung kommt?

Generell läuft das Modul super, nur manchmal habe ich am Tag 3-4 mal diese Meldung.

Danke und grüße

Stephan

Hallo Stephan,
ich bin ein bisschen ratlos. Welche Version verwendest du? Das ist nicht die V1.10, oder?
Grüße
Jürgen

Hi Jürgen,

vielen Dank für deine Rückmeldung.

Doch, ist die Version 1.10, warum?

image

Grüße
Stephan

ok, ich kann die Fehlermeldung nicht mit dem Code aus Zeile 226 in Zusammenhang bringen. Es scheinen aber falsche, ungewollte Daten anzukommen…
Es würde helfen, wenn Du den zur Fehlermeldung gehörigen Datensatz für mich rausfischen könntest.
Hast Du die Datensatzprüfung per Prüfsumme angeschaltet? Wenn nein, dann bitte anschalten.

Grüße
Jürgen

Hi Jürgen,

ich hab die Datensatzprüfung per Prüfsumme jetzt aktiviert.

Bisher hatte ich den Fehler nicht nochmal, sollte dieser wieder auftreten, werde ich zwecks dem zughörigen Datensatz schauen.

Danke bis hierher.

Grüße
Stephan

Hallo Jürgen,

ich bekomme immer wieder die Meldung. SML-String not valid. Es werden jedoch Werte angelegt und aktualisiert. Ich kann dir leider nicht sagen ob das jetzt erst mit dem letzten update kam oder schon von Anfang an so ist. Hast du eine Idee woran das liegen könnte?

Gruß Micha
dump.txt (46,3 KB)

Hallo Micha,
ich habe mir deine Datensätze mal durchgeguckt. Die beanstandeten Strings sind in der Tat nicht in Ordnung. Zum Teil fehlt etwas, zum Teil sind mehrere Teil-Datensätze zusammengeschmolzen. Das deutet für mich auf ein Hardware-Problem hin. Eventuell sitzt dein Lesekopf nicht exakt auf dem Zähler, so dass es immer wieder zu Aussetzern in der Datenübertragung kommt, oder die Baudrate ist falsch eingestellt. Es kann aber auch am Zähler selbst liegen.

Grundsätzlich bekommst du aber regelmäßig i.O.-Datensätze, so dass du, solange das Problem nicht schlimmer wird, die Fehlermeldung auch ignorieren kannst.

Grüße
Jürgen

Hallo Jürgen,

Danke das du es geprüft hast, ich hab den Übeltäter gefunden. Es lag an der tcp Bridge. Nach einem Neustart der Bridge kommen die Datensätze wieder sauber an.

Vielen Dank

Gruß Michael

1 „Gefällt mir“

Guten Morgen,

welche Bridge nutzt du und wie wird Symcon angebunden?
Gibts da ein usb to tcp gerät, welches auf Symcon Seite keine Hardware braucht?

Danke Sebastian

Morjen,

Ich habe einen hichi lesekopf der an einen esp8266 angeschlossen ist. Auf diesen läuft Tasmota als tcp Bridge.

Gruß Micha.

1 „Gefällt mir“