[Modul] openWB

Hallo,

ich habe den gleichen Fehler wie @Pulpcomputer.
Gibt’s dazu schon eine Lösung? Die Fehlermeldung müllt mir das Meldungsfenster zu.

Grüße
Proxima

Könnt ihr da mal das Debug zu generieren und schauen, bei welcher Variable das passiert?

Grüße,
Kai

Hallo @KaiS,

leider kommen die Fehler sporadisch und ich habe es noch nicht geschafft, ein Debug aufzuzeichnen, wenn der Fehler passiert.

Ich hänge mal ein Debug vom normalen Betrieb an, vielleicht hilft das ja schonmal.

Grüße
Proxima

dump.txt (18,3 KB)

Vom normalen Betrieb wird das leider nicht helfen.
Du kannst das Debug in eine Datei schreiben lassen, dann kannst du es so lange laufen lassen, bis der Fehler wieder auftritt, ich kann dann anhand vom Datum und der Uhrzeit schauen. :slight_smile:

Grüße,
Kai

Guten Morgen Kai,
Ich habe per MQTT die OpenWB laufen, meinst Du, es macht Sinn Dein Modul entsprechend umzubauen? Es scheinen alle Datenpunkte für eine komplette Fernsteuerung vorhanden zu sein…

Ja, klar macht das Sinn, aber mir fehlt aktuell die Zeit dafür.

Grüße,
Kai

Hallo,

@KaiS: Hier das gewünschte Debug.
Fehler traten auf um 12:49:53 und um 15:26:34.

debug_29035.txt (3,4 MB)

Gruß
Proxima

Ich werde versuchen das Modul auf MQTT umzustellen.

Grüße,
Kai

Ich habe angefangen das Modul auf MQTT umzustellen.
Bzw. ich habe parallel ein paar Instanzen hinzugefügt.

Will es jemand testen?

Danke an @bastelfrosch für das zur Verfügung stellen der Fernwartung.

Grüße,
Kai

1 „Gefällt mir“

Hallo Kai,

Immer her damit, dann teste ich es mal am Wochenende.

Gruß Sven

So nun habt ihr glaube ich ein paar Jahre gewartet. :smiley:
Es gibt nun eine Beta Version für die MQTT Version. :slight_smile:

Grüße,
Kai

Hallo Kai,

ich würde auch gern die MQTT-Version probieren.
Wo finde ich die, bzw. wie muss ich vorgehen?

Grüße
Proxima

Einfach die Beta Version vom Modul installieren.

Grüße,
Kai

Hallo,

also,wenn ich eine MQTT-Instanz des Moduls hinzufüge, bekomme ich alle ca. 90 Sekunden folgende Fehlermeldung:

23800 ist die MQTT-Server-Instanz.

Auszug aus dem Debug der MQTT-Server-Instanz:

192.168.2.146 ist die openWB.

Grüße
Proxima

Mach mal ne mqtt client instanz und verbinde den mit port 1883 der openWB, dann Kais Module verbinden.
Klappt bei mir einwandfrei

M.E. ist IPS hier Client und nicht Server

Moin,

hatte mich schon gewundert. Bei mir wurde immer eine Serververbindung vorgeschlagen.
Mit der Client Verbindung geht es problemlos.

@Kai danke für´s Modul

Hallo,

also bei mir klappt das nicht.
Könnt ihr bitte Eure Einstellungen des IPS-MQTT-Clienten und der openWB-MQTT-Brücke posten. Irgendwas mach ich da wohl noch falsch.

Vielen Dank.

Grüße
Proxima

Ich habe selbst gar keine openWB, das müsste jemand von den anderen machen.

Grüße,
Kai



_GW
Bitte sehr :slight_smile:

1 „Gefällt mir“