[Modul] Govee

Nein, ich möchte einfach mehrere Dinge ausprobieren.
Es gibt nichts spezielles was du noch liefern kannst.

Grüße,
Kai

@KaiS Planst du eigentlich auch noch Unterstützung für die Web-API bzw. ein eigenes Modul dafür?

Es gibt ja einige Govee-Geräte, die über keine lokale API verfügen.

Kannst bei mir sonst die Tage mal drauf gucken. Das mit dem nicht freien Port hatte ich auch. Muss nur erstmal etwas Zeit haben. Vielleicht am WE.

Ja, würde ich mir das gerne mal anschauen.

Grüße,
Kai

Moin in die Runde. Habe den gleichen LED-Streifen und 1 zu 1 die gleiche Thematik und Probleme wie vorher beschrieben. Ports waren angeblich belegt und die Discovery Instanz hat den Streifen nicht gefunden.
Erst nach einem Neustart war es mir möglich das DEVICE manuell zu konfigurieren bzw. den UDP-Socket.
Ich habe diese Woche Spätschicht… bei mir wäre es ab 23 Uhr möglich per Remote auf das System zu schauen. Nur als Angebot für Nachtschwärmer! haha…

Gruß,
Peter

Hallo Kai,

kann es sein, dass du noch (Debug-)Infos für die GoveeDevice Instanz ausgibst?
Im Aktualisierungstakt gibts folgende Ausgabe im Meldungsreiter:

02.04.2024, 07:14:02 | test                 | Array
(
    [msg] => Array
        (
            [cmd] => devStatus
            [data] => Array
                (
                    [onOff] => 0
                    [brightness] => 100
                    [color] => Array
                        (
                            [r] => 255
                            [g] => 0
                            [b] => 0
                        )

                    [colorTemInKelvin] => 0
                )

        )

)

Komisch ist, dass mich ein Doppelklick auf den Eintrag nicht zum „Verursacher“ bringt.

Ja, das ist noch ein Debug.
Weil die Funktion IPS_LogMessage genutzt wird, landest du nicht bei der Instanz.

Geht bei dir die Discovery Instanz?

Grüße,
Kai

Ja, Discovery Instanz läuft. Darüber habe ich meine LED Bulb String Ligths eingebunden.

Ich versuche mich gerade am Govee Modul. Mein Discovery zeigt auch nichts an.

Bei der Instanzkonfiguration des Multicast Socket (Socket geöffnet) lässt sich nichts einstellen.
Ab und zu kommt die Meldung:

Schnittstelle ist als fehlerhaft markiert. Bitte überprüfen Sie das Meldungsfenster für weitere Informationen.

Ich finde aber kein Meldungsfenster.

Sende Host ist ausgegraut
Sende Port grau 4001
Empf Host ist IP Adresse von IPS
Empf Port grau 4002
Multicast grau 239.255.255.250

Ich habe ein Govee Neon Rope Light 2.
IPS V7.1 Stable

Edit: Im Status liest man

03.04.2024, 09:15:03 | Multicast Socket     | Fehler beim Lesen: Es konnte keine Verbindung hergestellt werden, da der Zielcomputer die Verbindung verweigerte.

In der App lässt sich aber alles einstellen

Habt ihr eigentlich schon die Troubleshooting Session gemacht?

Ich habe jetzt das GoveeDevice per Hand installiert. Und alles Gut.

Ich hatte erst einen Multicast Socket installiert, aber beim Device erstellen kam auch gleich ein UDP Socket. Werte eingetragen und läuft… Egal ob Multicast oder UDP.
Welchen sollte man nun nutzen?

Nun kommt allerdings alle 10 Sek. der Testdebug…

Die Govee API gibt aber nicht viel her. Farbe, Farbtemperatur, Helligkeit und Status. Ich hatte gehofft dass zumindest noch die verschiedenen abgespeicherten Programme anwählbar währen.
Nun gut, man kann nicht alles haben…

Ich brauche für die Fehlersuche die Hilfe von @paresy.
Aktuell habe ich aber auch keine Zeit dafür, bin gestern Papa geworden. :slight_smile:
Deswegen empfehle ich euch erstmal die Geräte per hand anzulegen.

Nutze den UDP Socket.

Das fixe ich gleich.

Grüße,
Kai

Die neue Beta Version ist online.

Grüße,
Kai

Na dann erst einmal herzlichen Glückwunsch!!!

1 „Gefällt mir“

Dann mal herzlichen Glückwunsch ! Wir sehen dich dann in 2… 3 Jahren wieder wenn das gröbste vorbei ist. War nett mit Dir. :stuck_out_tongue:

1 „Gefällt mir“

Danke euch.
Quatsch, Updates kommen. :smiley:

Grüße,
Kai

Ich hab dich hier auch ganz vergessen. Meld dich einfach wenn du noch jemanden brauchst. Hab kommende Woche frei

Ich bin die nächsten 4 Wochen Zuhause.
Dann fange ich meinen neuen Job an. Also wir können, die nachsten Tag sicherlich mal gucken. :slight_smile:

Grüße,
Kai