[Modul] Volumio

IPS-Volumio
Mit diesem Modul ist es möglich Volumio per MQTT mit IP-Symcon zu verbinden.

1. Voraussetzungen

[ul]
[li]mindestens IPS Version 5.1
[/li][li]MQTT Server
[/li][/ul]
2. Enthaltene Module

[ul]
[li]IPS-Volumio
[/li][/ul]
3. Installation
Über den Modul Store!

4. Konfiguration in IP-Symcon
Bitte den einzelnen Modulen entnehme.

Die Dokumenation ist hier zu finden: Volumio | DeinSmartHome

Grüße,
Kai

17.08.2019: Version: 1.1
Fix - Profile für Radiosender waren nach einem Neustart von IP-Symcon defekt.

und muss sofort antworten.

Hallo Kai,
Perfekt, schick gemacht, leider zu spät. Nach dem ich mehrere Anläufe über Squeeze und auch Volumio gemacht habe bin in ein SONOS Fan geworden, danke an die vielen Hinweise und Bemerkungen der User hier im Forum.

Ich habe immer noch einen Volumio-Bastel-RasPi-Mit-Amp in der Wekstatt an einem geregelten 12V Netzteil hängen. In diesem Jahr wurde er noch nicht aktiviert - Er lacht mich gerade an und er wird bestimmt heute von innen Wärme ausstrahlen.

Freue mich auf ein PlayBack in der Werkstatt - Mazab :cool:

Gruß und Glück Auf
DVoss

PS: Es wird Zeit mein Livesystem in die Generation 5.x zu heben

Hi DVoss,

Sonos Fan’s sind wir auch, aber für draußen im Garten reicht auch mal Volumio oder was anderes in der Art.
Volumio mit dem MQTT Zusatz hat aber was für solche Dinge, und kostet als Bausatz nicht viel, und die Steuerung ist schon schnell.:eek:
So etwas würde ich mir in Zukonft von Sonos wünschen.

Hallo tomgr,

volle Zustimmung, hatte zum Thema Tasmota&MQTT auch meine Begeisterung geäußert. Das Volumio&MQTT legt nochmals die Latte höher. Danke an euch alle, es ist toll für mich zu lesen das meine Gedanken ohne sie zu veröffentlichen umgesetzt werden.

Ein weiterer Daumen hoch für eine einfache Umsetzung der Sonos Steuerung dazu muss der Hersteller etwas tun. Nicht nur mit der Alexa sprechen können oder neue Möbelstücke mit schwedischen Namen zu entwerfen. Es gehört auch eine schicke 3rd Party Schnittstelle / API dazu.

Bleiben wir Optimistisch: Auf das der nächste Tag für alle eine Besserung mit sich bringt.

Allen ein Glück Auf
D.Voss

Hallo Kai,

besten Dank für das Modul. Hast du mal irgendwo einen Link zum Thema Volumio und MQTT? Also die Seite
Volumio. Thema Topic usw. … Ich finde da nix und würde mich da gern mal einarbeiten.

Danke

Thomas

Bin zwar nicht Kai, aber das Modul von Kai werkelt nur bei mir.:smiley:
Schau mal : GitHub - richiewebgate/volumio-mqtt: NodeJS MQTT Adapter for volumio.org Player
Das muss so installiert werden, dann kann volumio MQTT sprechen.
Download |Get Started | Volumio ist auf dem Raspberry als Grundlage am laufen.

danke. genau das habe ich gesucht.

Thomas

Neue Version ist online, sobald IP-Symcon diese im Store freigegeben hat.
Solange kann die Beta Version aus dem Store genutzt werden.

Version 1.1:
Fix - Profile für Radiosender waren nach einem Neustart von IP-Symcon defekt.

Grüße,
Kai

Wie könnte so ein Eintrag bei MQTT Topic aussehen, bzw. wo finde ich den?

Moin,
du musst noch das in volumio installieren :
GitHub - richiewebgate/volumio-mqtt: NodeJS MQTT Adapter for volumio.org Player

Dann volumio-mqtt einrichten, passsiert in der config.js
Der Inhalt von meiner config.js:

module.exports = {
    "volumio_host": 'http://localhost:3000',
    "mqtt_devicename": "radio-01",
    "mqttHost": "mqtt://10.10.0.11:1883",
    "mqtt_tvenabledtopic": "tv/status/wohnen/enabled",
    "mqtt_powerToggleAddr": "knx/set/4/1/7",
    "debug":false
}

Dann bei KaiS Modul den MQTT Topic eintragen, in dem Beispiel aus meiner config ist das : radio-01
mqttHost ist bei mir der IPS Pi mit dem internen MQTT von IPS.
Achte auf die Port’s !

So läuft es bei mir, habe das vor fast einem Jahr eingerichtet und nicht mehr angefasst.:smiley:

Hallo Thomas,
ich habe das jetzt in der config.js vom Volumio angepasst, geht aber leider immer noch nicht. Vielleicht habe ich im IPS noch Fehler.
Stimmt denn der Eintrag im Objektbaum? Was mir seltsam erscheint ist der Eintrag der IP-Adresse vom MQTT Server Socket.

Schau dir mal die Port’s an, die scheinen nicht zu passen.
IPS hat 1024, die Config 1883, stell den MQTT Server mal von 1024 auf 1883 um !

Das hat leider nichts gebracht. Habe auch alles neu gestartet.

Passen denn diese Einträge zusammen?

module.exports = {
    "volumio_host": 'http://localhost:3000',
    "mqtt_devicename": "wohnzimmer",
    "mqttHost": "mqtt://192.168.1.5:1883",
    "mqtt_tvenabledtopic": "tv/status/wohnen/enabled",
    "mqtt_powerToggleAddr": "knx/set/4/1/7",
    "debug":false
}

„mqttHost“: „mqtt://192.168.1.5:1883“,

und was steht im IPS MQTT, immer noch 1024 ? Dann kann es nicht gehen, denn da muss auch 1883 rein !

Das hatte ich schon geändert. Was mich aber stört ist dort die IP 0.0.0.0:1883

Dann mach mal die eigene IP vom MQTT Server rein.
Aber wenn der interne MQTT Server auf einen Pi läuft, geht 0.0.0.0 !
Ist ja das eigene Gerät.

Wie ist hier der Stand, hat es geklappt?

Grüße,
Kai

Nein, ich komme da nicht weiter. Es baut sich keine Verbindung auf.

Hast du Volumio neugestartet?

Grüße,
Kai

Gesendet von iPhone mit Tapatalk