[Modul 6.0] Shelly

Hallo, hab eich getestet. Es sind nun die Variablen „Roller“ und „Position“ hinzugekommen, dieser sind jedoch als „Boolean“ definiert und funktionieren daher nicht. Die restlichen Variablen fehlen nach wie vor.

Es gibt eine neue Version.
Du musst die Instanz nochmal löschen und neu anlegen, dann sollten wieder die richtigen Variablentypen angelegt werden.
Welche Variablen vermisst du?
Darf ich mir das evtl. morgen mal per Fernwartung bei dir anschauen?

Grüße,
Kai

Danke, nun sind die Variablen korrekt. Gerne können wir uns die Konfig per Fernwartung ansehen. Was die fehlenden Variablen betrifft, so orientiere ich mich wie hier beim Shelly 2.5:


Diese würde es auch beim 2PM geben, aber eben noch nicht ersichtlich.

Ich glaube da hat es auch noch an ein paar anderen Stellen noch etwas :slight_smile:

Hallo Kai,
bei mir funktioniert es nun. Bisher habe ich keine Probleme, habe es aber auch nicht in Gänze getestet.
Viele Grüße
Marc

1 „Gefällt mir“

Guten Morgen Kai, ich bin jetzt zurück und habe mal den Feiertag genutzt, die nicht genutzten Variablen auszuschalten. Beim RGBW2 fehlen noch Werte oder sind doppelt vorhanden. Longpush z.B. sehe ich gar nicht, dafür sagt mir Effekt und Gain nichts :slight_smile:


Hallo Kai,
bei meinen Shelly Bulbs läuft wohl nun ein Fehler auf.

Vielleicht magst du ja mal nachschauen.

Viele Grüße
Marc

Input und Longpush gibt es nun mit der aktuellen Beta Version wieder, kannst du das testen?
Effekt und Gain gibt nicht, wenn der Typ auf „Weiß“ eingestellt ist.
Man sieht diese zwar in der Liste, aber die werden ignoriert, weil das Gerät die nicht benutzen kann.

Grüße,
Kai

Kannst du mal ein Debug erzeugen und posten?

Grüße,
Kai

Bin derzeit im Urlaub. Melde mich dann dazu.
Gruß
Marc

1 „Gefällt mir“

Alles klar, schönen Urlaub.

Grüße,
Kai

Hallo Kai,

wollte mal wieder den Konfigurator nutzen und dann kommt das:

Konnte Konfigurationsform von neuer Instanz nicht bestimmen
Warning: InstanceInterface is not available in /mnt/data/symcon/modules/.store/info.schnittcher.ips.shelly/ShellyConfigurator/module.php on line 584

Fatal error: Uncaught TypeError: strtolower() expects parameter 1 to be string, bool given in /mnt/data/symcon/modules/.store/info.schnittcher.ips.shelly/ShellyConfigurator/module.php:584
Stack trace:
#0 /mnt/data/symcon/modules/.store/info.schnittcher.ips.shelly/ShellyConfigurator/module.php(584): strtolower(false)
#1 /mnt/data/symcon/modules/.store/info.schnittcher.ips.shelly/ShellyConfigurator/module.php(36): ShellyConfigurator->getShellyInstances('ShellyBulbDuo-D...')
#2 /-(3): ShellyConfigurator->GetConfigurationForm()
#3 {main}
  thrown in /mnt/data/symcon/modules/.store/info.schnittcher.ips.shelly/ShellyConfigurator/module.php on line 584 (Code: -32603)

Nach ein paar Mal probieren geht es. Zudem habe ich ein paar Shelly Module aktualisiert. Kann das mit deren Firmware zusammenhängen?

Hallo ich habe eine Shelly3EM erfolgreich eingebunden jedoch mein neuen Shelly1PM bekomme ich nicht eingelesen. Kann mir da irgendjemand ein Tip geben, ich habe mal ein paar Screenshots angehängt.

Vielen Dank und Grüße!





Hast du den MQTT Server auch im Webinterface bei dem Shelly hinterlegt?

Grüße,
Kai

Das liegt nicht an der Firmware. Da war irgendwas mit einer Shelly Geräteinstanz nicht in Ordnung. Jetzt geht es wieder?

Grüße,
Kai

1 „Gefällt mir“

Ja ich habe mal durchprobiert mit Löschen von Instanzen und dann ging es wieder.

Hallo Kai,

hast Du geplant die Shelly Pro einzubauen?
Ich habe je einen Shelly Pro1 und einen Shelly Pro1PM beschafft.
Fotos

Viele Grüße aus dem Unterallgäu
Harry

Na klar. Es gibt ja schon einige Pro Instanzen.

Grüße,
Kai

Hallo Kai,

habe mir meine ersten Shelly Pro2PM beschafft. Leider funktioniert das Schalten von Symcon aus nicht.


Die Schalter zum Testen in der Instanzkonfiguration (Status 1 und Status 2) springen nach dem Schalten wieder auf Aus zurück und am Shelly tut sich nichts. Schalte ich allerdings vom Webinterface des Shelly, so wird der Status erkannt und die Schalter in der Instanzkonfiguration wechseln den Zustand.
Erwähnen sollte ich noch, daß ich bereits einen MQTT Server Configurator habe, der auf demselben MQTT Server mit demselben Server Socket läuft.
Grüße Oliver