Z-Wave, Fibaro Universal Sensor and DS18B20


I’m trying to get the combination of Fibaro Smart Implant and DC18B20 working.
When I add new device in Z-Wave convigurator, Fibaro appears but I do not see anything for connected DS18B20 temperature sensor.
Do I need to configure something in IP Symcon or should it appear automatically?


You must connect the DS18B20 first. After that You can include the fibaro.


I’ve done that.
Connected the sensor, learned the Fibaro in Z Wave Configurator.
That worked, I get the Fibaro instance and also updates.

But there’s nothing for connected sensor.
Unfortunately I do not have the knowledge to test whether sensor itself works but I tried two.

There are 8 channels in Fibaro node.
If I create them all, all appear as empty nodes.

Hi marian

Did you klick into the sub channels and load the configuration for each subchannel ?
Then you should get the variables.
If at least channel 7 is empty, then something must be wrong inclusion. Channel 7 is a device internal temerature sensor.

Look, this is how it shoudl look like:
The DS18B20 shoudl appear in channel 8.

Yes I did and it does not work for me.

Differences compared to your screenshot:

  • Channel nodes get created on the top level, not below Fibaro node
  • Channel nodes are empty, they have no properties.

I think I got it working, at least somewhat.
In the channel expert options, I turned on „Enforce basic class“
Then I got two properties Data (boolean) and Data (integer) for that channel, albeit with incorrect profile (showing percentage).
When I changed the profile I got the temperature reading.

But still my channel value is integer while in your screenshot it’s float.

And unfortunately it works only when I connect one sensor.
When I connect two of them, I get no updates.