OSX: IPS startet nicht nach update

Hallo zusammen,

Ich habe nach meinen Ferien ein Upgrade auf die neueste OSX version ausführen wollen.
Also habe ich von v. 95113c1c aus „Check for updates“ ausgeführt und kriegte folgende Fehlermeldung:

Sparkle Updater: Possible attack in progress!
Attempting to „upgrade“ from 144 to 1. Aborting update.

Nun, daher habe ich IPS halt von der Webseite geladen und und die Applikation unter Programme ersetzt (hoffe, es ist eine neue version und nicht uralt :confused:).
Nun crashte IPS und respawnte sich ständig. Das system wurde regelrecht lahm… Musste zurück auf mein Backup.

Folgendes erschien dann stets in den logs:


Date/Time:       2015-08-02 17:22:23.014 +0200
OS Version:      Mac OS X 10.9.5 (13F34)
Report Version:  11
Anonymous UUID:  C5E63922-1FDC-B21B-AEB2-D7B519D9B15C


Crashed Thread:  0  Dispatch queue: com.apple.main-thread

Exception Type:  EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000

Application Specific Information:
Assertion failed: (git_atomic_get(&git__n_inits) > 0), function git__global_state, file /Users/symcon/Downloads/libgit2/src/global.c, line 383.
 

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   libsystem_kernel.dylib        	0x00007fff8b66e866 __pthread_kill + 10
1   libsystem_pthread.dylib       	0x00007fff9492535c pthread_kill + 92
2   libsystem_c.dylib             	0x00007fff94cb5b1a abort + 125
3   libsystem_c.dylib             	0x00007fff94c7f9bf __assert_rtn + 321
4   ips                           	0x000000010186d3c4 git__global_state + 84
5   ips                           	0x0000000101862579 giterr_clear + 9
6   ips                           	0x00000001018e0231 git_sysdir_guess_global_dirs + 49
7   ips                           	0x00000001018df9d8 git_sysdir_get + 264
8   ips                           	0x00000001018df8b3 git_sysdir_global_init + 83
9   ips                           	0x000000010186d143 init_once + 99
10  libsystem_pthread.dylib       	0x00007fff949258d6 __pthread_once_handler + 65
11  libsystem_platform.dylib      	0x00007fff95d26156 _os_once + 73
12  libsystem_pthread.dylib       	0x00007fff94925875 pthread_once + 57
13  ips                           	0x000000010186d09b git_libgit2_init + 27
14  ips                           	0x0000000100fb195e SkinControl::SkinControl(IIPSKernelEx*, unsigned short, IPSBasicModuleInformation) + 1998
15  ips                           	0x00000001013b8bac IPSModuleFactoryEx<SkinControl>::createInstance(IIPSKernelEx*, unsigned short, IPSBasicModuleInformation) + 92
16  ips                           	0x000000010154bb24 IPSInstanceManager::ConnectInstances(std::__1::basic_string<char, std::__1::char_traits<char>, std::__1::allocator<char> >) + 900
17  ips                           	0x0000000101555b36 IPSKernel::InitKernel() + 1094
18  ips                           	0x00000001015530f5 IPSKernel::IPSKernel() + 8421
19  ips                           	0x00000001018160ea main + 170
20  libdyld.dylib                 	0x00007fff8f3a05fd start + 1

und im IPS log steht bei live update nur: Ninja-Version und das letzte was geloggt wird ist stets:

17:22:44 | 40493 | MESSAGE | Skin Control         | Creating...

Irgend eine Idee?

Gruss
pelota

Moin!

Virenscanner komplett abschalten und nochmal updaten. So als Idee :slight_smile:
Edit: Weil laut Google und anderen Foren tritt das Problem auf, wenn mit den heruntergeladenen Dateien vom Update irgendwelche Probleme sind (nicht mehr vorhanden/defekt und sowas).

IPSView hatte da auch kürzlich ein Problem beim Update mit manchen Virenscannern. Und ich hatte am Wochenende den Fall, dass mir der ClamAV alle meine IPS-Backups, welche auf dem NAS liegen, in die Quarantäne verschoben hat… :rolleyes:

Grüße,
Chris

Da hat sich leider eine fehlerhafte Version eingeschlichen. Bleib erstmal auf dem Backup!

paresy

Werd ich machen, danke