No data from Xcomfort battery sensors with CKOZ-00/14 interface on Raspberry Pi.


I hope you guys can help me even if I write in English, my German is terrible :slight_smile:

I have a Raspberry Pi with the newest Symcon version in demo mode and a CKOZ-00/14 USB interface.
I have added several different dimmers, switches, shutters etc and no problem with controlling these from Symcon.
But when adding battery sensors like binary inputs, temperature inputs and room temperature controllers I get no data from these.
When checking traffic in MRF 2.56 I see the data being sent on correct datapoint to usb interface but values are not updating in symcon console.

Strange that all mains powered devices are working and battery powered are not.
I also updated the firmware for the CKOZ-00/14 to RFPacket_CI_RFV2_11_USBV2_05.

Anyone have any good ideas?

No one?

Sent from my iPhone using Tapatalk

Could you check in the I/O Debug in IP-Symcon if there is any data coming in, when you e.g. press a button on the battery driven device?

(I know that you see data on the programming interface debug, but sometimes the MRF software messes up the connection to the gateways… :frowning: )


Hi, and thanks for your answer.

I used debug on both channels of a binary input on my garage doors and no input on either channels.
Also all battery sensors have status never updated in tree view.

I used this same usb interface with a windows computer and Symcon some years ago with no problem.
My plan was to change out all of my smart home controllers with raspberry and Symcon so this was a real show stopper.


Did some more testing and I am still not getting any signals from any sensors. Same status as before, signals showing sent on MRF traffic but nothing on the debug monitor for the datapoint in Symcon.

Anyone with a similar problem?
Nobody using Xcomfort anymore?

You said that it worked some time ago with IP-Symcon on a Windows system. Did you already try to use the devices with a Windows system on the current installation?

No I have not tried it with a windows system, I can do a test with an old laptop I have.

When I switch xcomfort relays on/off I still get no data on the corresponding debug screen for the datapoint. That is also strange.

Sent from my iPhone using Tapatalk

Tested with a Windows system but same problem.
Must be the firmware on the usb interface that is the problem.

MRF showing signals is sent to usb interface but no answer.

Sent from my iPhone using Tapatalk

Have you opened the „Debug“ on the sensor instance? Or on the I/O Instance (should be HID)? You want to open it on the HID instance, to show all traffic. Is the firmware of your USB-Stick up to date?


Yes I have updated the firmware 3 times just to be sure the update was not faulty.
The firmware was the newest I could find on the Eaton webpage, RFPacket_CI_RFV2_11_USBV2_05.

On the HID I can see the traffic when operating my shutter actuators. I can also see a „watchdog“ every 1 minute being sent.
But I get NO traffic when toggling my binary input or „waking up“ my room controller thermostat to send temperature.: Banghead:

dump.txt (5.57 KB)

That seems to be the issue :frowning: Have you tried to reprogram the effected devices again? Maybe try to disconnect the device from the gateway und reconnect it, so i gets a new DP number. Afterwards just update the DP in IP-Symcon.


I have done that several times. I also talked to Eaton and got the previous version of the usb stick firmware now to test. After downgrading firmware I deleted my whole Xcomfort configurator and reloaded all datapoints but still the same problem.

I see in the MRF traffic monitor that no received „confirmation“ is sent from the USB interface when sensors are sending signals. I have sent an email to Eaton as I guess this is not a problem with Symcon?!

As long as the interface does not receive any data, we cannot do anything about it. :frowning: I am nur sure if the simple status messages will send an ACK - ACK and Routing for status messages was just recently implemented for the new switch/dimmer devices. Older devices did not Route/ACK any status messages.