Neue Beta: Gerätesuche und Aktionen

Es gibt ein Update der Beta. Darin kommt nun analog zum Update von Alexa die Gerätesuche und ein Umbau der Szenen. Szenen rufen nun nicht mehr zwangsweise Skripte auf, sondern führen eine beliebige Aktion aus.

Ich bin auf euer Feedback gespannt!

Thanks for the new beta. I’ve changed several scenes from script to action. One action doesn’t seem to work, however. The same action called by script works as expected. The action is of the type „Group Control“. The highlighted scenes work when being activated using a Google Assistant voice command, the scenes in red don’t work when being activated using a Google Assistant voice command.

The PHP Script (which is the same as the Group Control action):

<?php
//Start writing your code here
RequestAction(26475, 2);
?>

I’m not sure this is an issue with the new beta, or with Google Home/Assistant. A household member has incorrect Scenes, they are different from the household creator (owner). It looks like they’re not updated.


Dennis

Could you open the Debug Log of the Assistant and then try to trigger the Group Control scene? Then, some debug info should appear. If you could download that and send it to me via PM (or just post here), I could take a look what is going on.

I don’t think there is much we can do if different scenes are shown for different household members. When the module returns the current devices (including scenes) it does so independently of the household member. I think there is either an issue with the Assistant or the configuration.

Hi @Dr.Niels ,
I’ve opened a debug log, and now it works as expected. :roll_eyes:
Yesterday I tried the same action multiple times, all failing. Today I do the same, and it works. Great! :grinning:

The different scenes available to household members seems to be an ongoing story for a few years now, with no solution in sight. There has been a change (made by Google) how scenes are handled, and since then these problems are prevalent. If a household member enables VoiceMatch it’s even worse.

Thanks!

Another question, all my Eltako dimmers are recognized as a normal Light Switch when using device search. Is this expected behaviour?

The device search is implemented such that it rather finds too much than too less. The search depends on the used variables. A variable with a ~Switch profile is interpreted as light switch, a variable with an ~Intensity.X profile as dimmer. If an instance has both, it is also offered as expert light.

Is your dimmer only detected as regular switch or is it also found in the other light categories? If it is not found within the other categories, what profile does the dimmer variable use?

Thanks for your reply.

The instance uses 2 variables, „Status“, which uses profile „~switch“, and „Intensity“, which uses profile „~intensity.100“. The instance is offered as „Light (Switch)“ and „Generic Switch“.
There is one light offered as „Light (Dimmer)“, but that one is using the variable „Brightness“ which uses profile „~intensity.100“ (Twinkly).



That sounds like it should be offered as Light (Dimmer) and Light (Expert) as well… Could you send me your settings.json via PM? Then I can double check why it is not properly detected.

Thanks for the settings! I realized that you already have the intensity variable implemented in your Google Assistant as Light (Dimmer). The device search only considers variables that are not used yet. Thus, it only considered the Status variable.

1 „Gefällt mir“

Now I get it, device search only shows variables I haven’t configured before manually, when device search didn’t exist. That makes sense.