Nach Update von heute ThreadCount bei 25

Ich habe eben auf die aktuelle 6.2 Stable von heute aktualisiert.
Nach einer Weile habe ich mich gewundert, dass diverse Dinge im Haus nicht mehr funktionierten. Ich habe dann noch mal die Konsole angeschmissen und wurde von hunderten Warnings „Zeitüberschreitung beim Warten auf Skript…“ begrüßt. Dabei handelte es sich ausnahmslos um Skripte, die irgendwas auf den KNX-Bus schreiben. Der I/O war aber ganz normal offen und empfing auch Daten, mal abgesehen davon, dass ich wieder alle Telegramme wegen des KNX-Bugs in der 6.2 doppelt bekommen habe.

Ich habe dann noch einen Blick in die PHP Threads geworfen. Dort die nächste Überraschung. Die Größe der Queue hat sich auf 25 verringert, obwohl unter den Spezialschaltern noch der korrekte Wert (50) drin steht.

Ich habe dann den Dienst noch mal neu gestartet. Die Warnings kamen danach nicht mehr und die damit verbundenen Probleme waren weg, die Thread Queue war aber immer noch beschnitten. Bin dann in die Spezialschalter, habe zur Sicherheit die Einstellungen dort noch mal neu gespeichert, Dienst erneut gestartet, aber immer noch eine Queue von 25.

Wie kriege ich die Queue wieder auf ihren ursprünglichen Wert? Und wer weiß, was vielleicht noch alles an den Spezialschaltern nicht mehr übernommen wird…

Hat jemand eine Idee, woher das plötzlich kommt? Vor dem Update war ich auf 6.2 Rev. 935f10f614c8 (Windows).

Magst du Testweise mal auf 60 stellen? Was passiert dann?

Wir haben das Minimum tatsächlich von 50 auf 25 reduziert (Default ist aber immer noch bei 50 bei neuen Installationen) und sollte auch 50 sein, wenn der Spezialschalter 50 sagt. (Wir würden es nur auf min. 25 erhöhen, wenn du den Spezialschalter z.B. auf 10 stellst)

Hast du auch bei ThreadCount geschaut und nicht bei ThreadQueueLimit?

paresy

Ich Depp. Natürlich habe ich jedes Mal auf ThreadQueueLimit geschaut und den korrekten Schalter überlesen. :banghead:

Dennoch passt da was nicht. Denn ThreadCount stand jetzt bei mir nach dem Update auf 20 (vorher 50). Deiner Aussage nach hätte ich hier aber - wenn überhaupt - eine 25 erwartet. Wobei eigentlich hätte ich erwartet, dass sich durch ein Update überhaupt nichts ändert. Ich hatte den Wert ja vor langer Zeit mal aktiv von 25 auf 50 angehoben.

Aber beruhigend zu wissen, dass der Schalter grundsätzlich noch funktioniert und ich nur Tomaten auf den Augen hatte. :roll_eyes:

Korrekt. 25 sollten es dann sein - was deiner Aussage nach auch so übernommen wurde. Ich vermute du hattest damals auch den falschen Schalter angehoben (ThreadQueueLimit ist 25 standardmäßig und nicht 50) - denn die Einstellung der Spezialschalter haben wir nicht verändert. Wir haben nur das Minimum reduziert, wodurch es bei dir von 50 auf 25 reduziert wurde, da dein Wert auf 20 stand.

paresy

Ja, scheint wohl so zu sein. :confused: Habe mir gerade mal eine alte Settings angesehen und dort steht auch 20 drin. Keine Ahnung, was ich damals gemacht habe. Jedenfalls hatte ich anfangs mal 25 Threads und nach meiner Anpassung waren es 50 (oder es hat sich da zufällig irgendwas mit einem Update überschnitten).

Egal, in Zukunft einfach Augen auf, dann kalppt’s auch mit den Settings. :wink:

@paresy: Besteht hier denn nicht die Möglichkeit, den Spezialschalter in ‚ThreadCount - min. 25‘ umzubenennen und den Wert beim Start anzupassen, anstatt ihn intern zu überschreiben? So ist für den Nutzer klar ersichtlich, was hier passiert.

1 „Gefällt mir“