[Modul 6.0] Shelly

Jetzt hab ich es verschlimmbessert:

19.10.2021, 20:12:18 | DNSSD Control | Fehler beim Warten auf Dienstrückgabewert: Fehler 87

das kommt wie SPAM im Meldungsfenster.
Symcon reagiert nicht mehr. Service lässt sich nicht stoppen…

Nutzt Du Firefox als Browser? Ich habe den gleichen Fehler im Zusammenhang zwischen dem Modul und Firefox.

https://community.symcon.de/t/dnssd-control-fehler-beim-warten-auf-dienstrueckgabewert/52098/12?u=attain

Nein, verwende den Chrome. und ich verwende die DNSSD Instanz gar nicht. Die ist komplett leer.

Hab jetzt einen Snapshot von gestern eingespielt. Das alte Modul und der Spuk ist vorbei. Blöderweise kann ich so den Shelly Button nicht nutzen.

Wie leer?
Die wird vom Shelly Konfigurator benutzt. Und von Homekit und von Symcon selbst.
Michael

So leer:

und im Meldungsfenster schaut es so aus, sobald ich versuche einen Shelly zu schalten:

Das führt dann dazu, dass das Actionscript, das auf der Variable Status liegt -zig mal gestartet wird:

Wenn ich den Schaltbefehl (requestaction) aus dem Script auskommentiere, treten die Fehler nicht auf. Auch das Script wird nur einmal gestartet.

LG
Hugo

Du hast den Befehl hoffentlich nicht in einem Aktion-Skript verwendet welches der gleichen Variable zugeordnet ist.
Michael

O-oh…
Ja hab ich, Schande über mich…
Ich hab den alten Befehl, der ja über die Instanz geschaltet wird mit requestaction auf die Variable ersetzt.

Aber warum hast du überhaupt ein Aktions-Skript?
Die Variable ist doch schon ab Werk bedienbar (hat eine Aktion).
Michael

Damit je nach Präsenzstatus z.B. die Ausschalttimer gesetzt werden können. Ich muss das Konzept vermutlich komplett überarbeiten.

Ich finde MQTT echt super, aber irgendwas stimmt hier noch nicht. Ich habe 2 Shelly’s am laufen und die funktionieren auch. Allerdings bekomme ich Fehler im Log und das immer wieder, aber leider nicht regelmäßig.

Hat jemand eine Idee wie man die weg bekommt? Die nerven echt sehr.

Das ist ein Fall für @paresy.

Grüße,
Kai

Hallo ich versuche gerade einen der neuen Shelly Pro 4PM einzubinden - scheitere aber leider.
Im Shelly Configurator taucht das Gerät zwar auf, ich kann es aber nicht automatisch erstellen lassen.
Wenn ich manuell einen 4Pro anlege, wird nur ein, zwei mal die Erreichbar Variable geupdatet, hört dann aber auch wieder auf.
Schalten bzw. Leistungswerte empfange ich gar keine…
Symcon sowie Shelly wurde neu gebootet… hat noch jemand eine Idee??

Dieses Gerät ist noch nicht integriert, weil es eine neue API gibt und ich das Gerät nicht habe.

Grüße,
Kai

Das erklärt Vieles. :slight_smile: Kann ich mit irgendwelchen Infos dienen? Bringt dir das was?

Ich brauche Zugriff zu so einem Gerät, den werde ich wahrscheinlich bald von @paresy bekommen.

Grüße,
Kai

Da mir das Gerät ohne Auswertung durch Symcon gar nicht soooo viel Spaß bereitet, könnte ich es dir gerne auch für eine Implementierung ausleihen. Bei Interesse bring ich es zur Post! :wink:

Hallo Kai,
dann ist Shelly 1 Plus auch noch nicht drin, oder?

Nein leider noch nicht.

Grüße,
Kai

Kein Stress, Du hast genug zu tun, der kann UDP und Http.
Pass auf Dich auf