Kein Backup unter aktuellen Raspberry OS möglich

Hallo,

ich brauche bitte Hilfe.

Ich habe einen Pi 4 mit aktuellen OS aufgesetzt und IPS Installiert, Backup zurückgespielt, es läuft.

Aber ich kann kein Backup machen.

Symcon zuerst stoppen,

cd /var/lib/symcon/ eingeben

funktioniert nicht, Meldung = -bash: cd: /var/lib/symcon/: Keine Berechtigung

Mit sudo geht es auch nicht.
Bei Buster ging das wie in der Doku.

Was muss ich machen, soll ich mit sudo chmod 777 das Verzeichnis freigeben oder mache ich mir da was kaputt??

Danke.

ich mache das als User root. Wenn du User Pi bist, immer schön mit sudo arbeiten.

mit sudo geht es auch nicht, hatte ich schon probiert.

Mit sudo su
dann commands eingeben, jetzt läuft es.

Ich mache mir einmal die Freigabe und habe keinen Stress :drooling_face:

Also irgendwas stimmt trotzdem nicht.

Ich habe Testweise eine Kategorie erstellt und von 3 Instanzen die Abfrageintervalle verändert.

Dann ein Backup gemacht, dass lief Fehlerfrei durch.
Die Eigenschaften der Backup Datei waren vom Zeitstempel her unverändert, da war ich schon skeptisch.
Dann habe ich das Backup gemäß der Doku zurückgespielt und die Änderungen waren wieder rückgängig gemacht worden.
Die angelegte Kategorie ist verschwunden und die Abfragintervalle waren wieder so wie vor der Änderung.

Folgende Befehle habe ich ausgeführt.

sudo /etc/init.d/symcon stop
sudo su
cd /var/lib/symcon/
zip -r ~/backup.zip *
sudo /etc/init.d/symcon start

Die Backup.zip liegt in /home/pi Verzeichnis

Kann sich das jemand erkären, ich kann jetzt quasi kein Backup machen.
Beim Buster OS hat sich bei dieser Datei immer die Dateigrösse und der Zeitstempel geändert, ich habe das jedesmal kontrolliert.

Liegt es evtl. an der Berechtigung?

Wäre sudo chmod var/lib/symcon 777 falsch, mache ich mir da was kaputt?

Ich bin leider nicht der Linux Profi.
Ich kann mich aber auch nicht daran errinern das ich unter Jessie diese Situation hatte, vorher war ich mit IPS auf Windof.

Keine Ahnung, ich verstehs nicht.

Der macht das Backup nach Anmeldung als Superuser, aber wo wird es hingzippt?

Berechtigungen im home/pi/ sind auf 777, also es darf rein schreiben.
Linux macht mir da aber keine Backup.zip rein.

Ich verstehe meinen Fehler nicht.

/root/ müsste es sein.

paresy

Hallo Paresy,

danke da ist was drin. Aber warum jetzt im root Verzeichnis?
pi@raspberrypi:~ $ sudo su -

SSH is enabled and the default password for the ‚pi‘ user has not been changed.
This is a security risk - please login as the ‚pi‘ user and type ‚passwd‘ to set a new password.

root@raspberrypi:~# cd /root/
root@raspberrypi:~# cd /root
root@raspberrypi:~# ls -la /root/
insgesamt 380004
drwx------ 5 root root 4096 21. Jan 21:44 .
drwxr-xr-x 18 root root 4096 30. Okt 13:36 …
-rw-r–r-- 1 root root 389080400 21. Jan 21:44 backup.zip
-rw------- 1 root root 996 21. Jan 21:46 .bash_history
-rw-r–r-- 1 root root 571 9. Okt 16:21 .bashrc
drwx------ 2 root root 4096 30. Okt 13:36 .cache
drwxr-xr-x 3 root root 4096 21. Jan 16:28 .local
-rw-r–r-- 1 root root 161 9. Okt 16:21 .profile
-rw-rw-rw- 1 root root 253 21. Jan 17:32 .symcon
drwx------ 3 root root 4096 21. Jan 16:22 .vnc
root@raspberrypi:~#

Gilt jetzt die Backup Vorgehensweise analog zur Doku, nur mit anderen Pfaden.?
Ich habe jetzt /root mal auf 777 gesetzt.

Mit Bullseye musste ich auch erst eine CHMOD 777 auf das IPS Verzeichnis machen, sonst konnte ich auf Grund der Berechtigungen kein Restore machen.
Bei Buster war das zuvor nie nötig.
VG Doc

Na ja, mit Linux habe ich seit 10 Jahren nix mehr am Hut, ausser der Pi für Symcon.
Aber es hat jetzt Anscheinend geklappt.
Das Symcon Verzeichnis habe ich nicht auf 777 Vollzugriff setzen müssen.

Also für die anderen die das selbe Problem haben:

Backup erstellen

sudo su -
chmod 777 /root/
und dann wie gehabt

Das Backup.zip liegt dann im /root/ Dir

Backup wiederherstellen.
sudo su -
sudo /etc/init.d/symcon stop
cd /root/
sudo unzip backup.zip -d /var/lib/symcon/

Symcon starten.

@paresy Hab ich das irgendwo überlesen, oder ist das noch nicht dokumentiert, dass bei Bullseye z.B. das anders ist?

Ich hatte das auch schon mal, weiss aber nicht mehr, wie es damals gelöst wurde.

Mit ‚sudo su‘ wird doch auf den User „root“ geschaltet.
Könnte IPS als User „root“ installiert worden sein ?
Normalerweise wird doch IPS mit dem User „Pi“ ggf. mit ‚sudo‘ nicht aber mit ‚sudo su‘ installiert? oder?

Hi,

Also mit sudo su - sicher nicht.
Ich glaube das ich mit sudo installiert habe.

Dein Problem ist das su bzw. die Tilde.

Mit su = switch user wirst du root, mit Tilde erreicht man das Home Directory, in deinem Code nach su also das vom root.

Gibt doch beim zip einfach den richtigen Pfad an, da wo du es hin haben möchtest, also z. B. /home/pi/…

2 „Gefällt mir“

Hallo zusammen,

ich habe am Wochenende einen meiner Raspberrys neu mir Raspbian OS Bullseye neu aufgestzt und Symcon aus einer Sicherung wiederhergestellt. Da es sich bei dem verwendeten Raspi um einen übrigen Raspi 2 handelt, wollte ich mit diesem nur das System am Laufen halten und den Fehler in IPS suchen.
So weit so gut. Der aktuelle neuere Raspi läuft wieder und ich wollte von alten Interims Raspi eine IPS Sicherung erstellen. Und hier beginnt das Problem.-

Bei cd / var/lib/symcon kommt die Fehlermeldung, dass ich keine Berechtigung habe.

Ich bin nicht wirklich fit mit Linux und komme hier einfach nicht weiter. Mit root Rechten lässt sich die Sicherung anstoßen, aber wo finde ich die Sicherungsdatei denn dann?

Es wäre schön wenn mir jemand helfen könnte.

Danke und viele Grüße

Joerg

Nachdem ich dein Beitrag zum gleichen Thema angefügt habe, findest du die Antwort auf deine Frage über deiner Frage. :laughing:
Michael

Hallo Ralf,

danke für die Info, icht teste es beim nächsten Backup.

Prima… vielen Dank. Versuche ich heute Abend und werde dann berichten.

Joerg