Ich habe schwierigkeiten null zu erreichen

Moin, Moin,

seid ein paar Tagen erhalte ich folgende Meldung, wenn ich Alexa den Befehl: „Schalte das Deckenlicht ein“

ich habe schwierigkeiten null zu erreichen

Ich habe nichts geändert. Bisher funktionierte das alles. Aber jetzt kann ich machen, was ich will,- ich kann das System nicht mehr via Alexa steuern. Ich nutze ganz normal den Symcon-Skill und folgende Logs werden kreiert:

08.04.2022 20:07:38 | 51131 | MESSAGE | Connect Control      | [63] Neuer Kanal erstellt
08.04.2022 20:07:38 | 51131 | MESSAGE | Connect Control      | [63] Verbinde mit 127.0.0.1:3777...
08.04.2022 20:07:38 | 51131 | MESSAGE | Connect Control      | [63] Verbunden mit lokalen Server
08.04.2022 20:07:38 | 51131 | MESSAGE | Connect Control      | [63] Erkannte URL... /oauth/amazon_smarthome/
08.04.2022 20:07:38 | 51131 | MESSAGE | Connect Control      | [63] Lese entfernte Daten... 1909 bytes
08.04.2022 20:07:38 | 51131 | MESSAGE | Connect Control      | [63] Schreibe entfernte Daten...
08.04.2022 20:07:38 | 51131 | MESSAGE | Connect Control      | [63] Schreibe entfernte Daten... 1909 bytes
08.04.2022 20:07:38 | 51131 | MESSAGE | Connect Control      | [63] Lese lokale Daten... Limit: 65536
08.04.2022 20:07:38 | 51131 | MESSAGE | Connect Control      | [63] Lese lokale Daten... 417 bytes
08.04.2022 20:07:38 | 51131 | MESSAGE | Connect Control      | [63] Schreibe lokale Daten... Verfügbar: 417, Fenster: 24576
08.04.2022 20:07:38 | 51131 | MESSAGE | Connect Control      | [63] Schreibe lokale Daten... 417 bytes
08.04.2022 20:07:38 | 51131 | MESSAGE | Connect Control      | [63] Lese entfernte Daten... EOF
08.04.2022 20:07:38 | 51131 | MESSAGE | Connect Control      | [63] Lese lokale Daten: Geschlossed
08.04.2022 20:07:38 | 51131 | MESSAGE | Connect Control      | [63] Alter Kanal freigegeben. Übrigbleibende Kanäle: 0
08.04.2022 20:07:39 | 51131 | MESSAGE | Connect Control      | [64] Neuer Kanal erstellt
08.04.2022 20:07:39 | 51131 | MESSAGE | Connect Control      | [64] Verbinde mit 127.0.0.1:3777...
08.04.2022 20:07:39 | 51131 | MESSAGE | Connect Control      | [64] Verbunden mit lokalen Server
08.04.2022 20:07:39 | 51131 | MESSAGE | Connect Control      | [64] Erkannte URL... /oauth/amazon_smarthome/
08.04.2022 20:07:39 | 51131 | MESSAGE | Connect Control      | [64] Lese entfernte Daten... 1898 bytes
08.04.2022 20:07:39 | 51131 | MESSAGE | Connect Control      | [64] Schreibe entfernte Daten...
08.04.2022 20:07:39 | 51131 | MESSAGE | Connect Control      | [64] Schreibe entfernte Daten... 1898 bytes
08.04.2022 20:07:39 | 51131 | MESSAGE | Connect Control      | [64] Lese lokale Daten... Limit: 65536
08.04.2022 20:07:39 | 51131 | MESSAGE | Connect Control      | [64] Lese lokale Daten... 696 bytes
08.04.2022 20:07:39 | 51131 | MESSAGE | Connect Control      | [64] Schreibe lokale Daten... Verfügbar: 696, Fenster: 24576
08.04.2022 20:07:39 | 51131 | MESSAGE | Connect Control      | [64] Schreibe lokale Daten... 696 bytes
08.04.2022 20:07:39 | 51131 | MESSAGE | Connect Control      | [64] Lese entfernte Daten... EOF
08.04.2022 20:07:39 | 51131 | MESSAGE | Connect Control      | [64] Lese lokale Daten: Geschlossed
08.04.2022 20:07:39 | 51131 | MESSAGE | Connect Control      | [64] Alter Kanal freigegeben. Übrigbleibende Kanäle: 0
08.04.2022 20:07:39 | 49540 | MESSAGE | VariableManager      | [Wohnzimmer\Echo Show Wohnzimmer\Letzte Aktion] = 1649441259
08.04.2022 20:07:40 | 51131 | MESSAGE | Connect Control      | [65] Neuer Kanal erstellt
08.04.2022 20:07:40 | 51131 | MESSAGE | Connect Control      | [65] Verbinde mit 127.0.0.1:3777...
08.04.2022 20:07:40 | 51131 | MESSAGE | Connect Control      | [65] Verbunden mit lokalen Server
08.04.2022 20:07:41 | 51131 | MESSAGE | Connect Control      | [65] Erkannte URL... /api/
08.04.2022 20:07:41 | 51131 | MESSAGE | Connect Control      | [65] Lese entfernte Daten... 237 bytes
08.04.2022 20:07:41 | 51131 | MESSAGE | Connect Control      | [65] Schreibe entfernte Daten...
08.04.2022 20:07:41 | 51131 | MESSAGE | Connect Control      | [65] Schreibe entfernte Daten... 237 bytes
08.04.2022 20:07:41 | 51131 | MESSAGE | Connect Control      | [65] Lese lokale Daten... Limit: 65536
08.04.2022 20:07:41 | 51131 | MESSAGE | Connect Control      | [65] Lese lokale Daten... 177 bytes
08.04.2022 20:07:41 | 51131 | MESSAGE | Connect Control      | [65] Schreibe lokale Daten... Verfügbar: 177, Fenster: 24576

Ich habe am System aber keinerlei Änderungen vorgenommen. Ich habe den RaspberryPi schon neu gestartet auf dem Symcon läuft, aber auch das hat nix gebracht. Kann mir jemand helfen?

Lasse Alexa mal nach Geräten suchen

Moin Senior. „Einfach“ nur danach suche,- hatte ich auch schon gemacht. Aber ich habe dann gestern auch mal einen Schalter in der Amazon Alexa-Instanz gelöscht und wieder hinzu gefügt. Siehe da,- alles funktionierte wieder. Heute morgen dann das tägliche Ritual: „Alexa, schalte den Arbeitsplatz ein“ und als Antwort bekomme ich wieder: „Ich habe Schwierigkeiten, null zu erreichen“ arrrrr…

Schau mal bitte im Debug von der Alexa Instanz. Was passiert dort?

paresy

Hier mal das entsprechende Log. Ich kann damit leider wenig anfangen
dump1.txt (675,9 KB)

Hallo Zusammen, bei mir tritt genau der gleiche Fehler auf, auch der Zeitraum seit wann, passt ungefähr zu dem von Thomas.

@paresy Ich hab gerade mal schnell getestet und der Fehler tritt immer beim Neustart auf. Sobald ich dann etwas ändere und die Einstelungen in Alexa Core anwende, funktioniert es wieder.

Tritt der Fehler auf, finde ich nichts im Debug Log von Alexa.

Ah, OK… Das kann natürlich sein denn das Backup-Script startet das System in der Nacht neu.

@paresy eine Idee für ein Workaround?

Jep,- sehr gute Frage denn im Laufe der Zeit hat sich die Bedienung via Alexa bei mir durch gesetzt. Backups aussetzen ist keine Lösung und auch jeden Morgen eine Veränderung vornehmen ist nicht wirklich praktikabel.

@Dr.Niels Hast Du ne Idee was man hier machen kann? Meine ganze Steuerung basiert auf Alexa, ich bin ziemlich aufgeschmissen, wenn das nicht geht :frowning:

Also das ist auch der einzige Grund, warum ich die Subscription zahle. Wenn es läuft, dann läuft es. Ich mache allerdings grundsätzlich regelmäßig Updates damit das System eben so sicher wie möglich ist. Zumal mein IPS eben nach außen gelegt ist. Wo ich ursprünglich in jedem Raum mit einem Tablet arbeiten wollte, hat sich seit Alexa eigentlich alles erledigt. Daher gibt’s teilweise gar keine Schalter mehr. Wenn das auf einmal nicht mehr funktioniert und Lösungen nicht in Sicht, ist das natürlich sehr ärgerlich.

Könnt ihr mir mal eure settings.json per PM schicken? Dann versuche ich mal die Fehler beim Neustart nachzustellen… Aktuell habe ich leider noch keine Idee, was da schiefgeht

@ThomasR Danke für das Backup! Darin habe ich gerade noch das alte Alexa-Modul IQL4SmartHome entdeckt. Es wundert mich, dass es da bisher keine Probleme gab, aber die beiden Module funktionieren nicht gemeinsam und machen sich gegenseitig den WebHook streitig. Das würde auch zur Erörterung passen, dass nach einem Übernehmen wieder alles funktioniert, denn dann schnappt sich wieder das „richtige“ Modul den WebHook. Lösche also bitte einfach mal das IQL4SmartHome Modul. Wenn es danach immer noch zu Fehlern kommt, schicke mir einfach nochmal eine aktualisierte settings.json.

Moin Niels, ja, das war die Lösung. Bisher gab es keinerlei Probleme mit diesem Modul. Das Backup vergangene Nacht hat das System auch überstanden.