Heizkörperthermostate auf Auto stellen

Hallo,

der Befehl:
HM_WriteValueBoolean(12345,‚AUTO_MODE‘,true);

bringt bei mir Fehler:
Warning: Use of undefined constant ‚AUTO_MODE‘ - assumed ‚‚AUTO_MODE‘‘ (this will throw an Error in a future version of PHP) in C:\ProgramData\Symcon\scripts\47933.ips.php on line 7

Warning: HomeMatic Fehler: Unknown parameter in C:\ProgramData\Symcon\scripts\47933.ips.php on line 7

Wie kann ich denn die Thermoste auf AUTO oder MANUELL stellen?

Besten Dank!!! Andreas

Welche Thermoste (Typenbezeichnung)? Es gibt diverse und entsprechend viele verschiedene Datenpunkt.
Die Liste der Homematic-Datenpunkt ist in der Doku unter Tips & Tricks zu finden.

Dein Beitrag und die Fehlermeldung passen nicht zusammen. Bitte benutze im Forum den Button ‚Vorformatierter Text‘ sonst zerlegt das Forum dein Script.
So sollte der Fehler nicht mehr auftreten, aber ob der Datenpunkt AUTO_MODE korrekt ist?!
HM_WriteValueBoolean(12345,'AUTO_MODE',true);
Michael

Wie Michael schon schreibt kommt es auf das Modell und den richtigen Datenpunkt an.

Meistens schaltet man den Modus aber über „CONTROL_MODE“ ((0:Auto, 1:Manual, 2:Holiday / Party)


        $ret = HM_WriteValueInteger($pid, "CONTROL_MODE", 0);

Gruß Heiko

Bei HmIP (HmIP-BWTH, HmIP-eTRV-2, HmIP-eTRV-E, HmIP-WTH-2) ist der analoge Datenpunkt SET_POINT_MODE (0=auto, 1=manuell)

Meiner Meinung nach stimmt die Aussage so nicht 100%!

Richtig, der Modus wird am gerät am Datenpunkt „SET_POINT_MODE“ angezeigt …

Beispiel (WTH-2)

Aber geschalten wird er über den Vater (HEATING_CLIMATECONTROL_TRANSCEIVER) mit CONTROL_MODE wie oben geschrieben.

Schlagt mich wenn falsch - habe es bei mir gerade nochmal nachgeschaut!

Gruß Heiko

bei den alten HM-Teilen (zB HM-CC-RT-DN) hiess das CONTROL_MODE

Hi @demel42 ,

nicht das wir uns falsch verstehen, Du hast richtigerweise den Datenpunkt aufgezeigt - absolut d’accord!

Nur ein schalten via …

 $ret = HM_WriteValueInteger($pid, "SET_POINT_MODE", 0);

geht eben nicht, auch bei den neuen WTHs eTRVs usw. nicht!

Gruß Heiko

ja, absolut korrekt. HM ist schon immer etwas verwirrend, was die Kanäle angeht und leider ist die Doku als Riesen-PDF auch nicht wirklich lesbar.

Es handelt sich um die ganz alten (nicht IP) HM-CC-TC.
Wie lautet da der Befehl?

Wie geschrieben, einfach mal „CONTROL_MODE“ ausprobieren. Bei mir funktionieren damit HM und HmIP Geräte!

das hat leider nicht funktioniert…

Müsste ich nicht dann auch bei den Geräten eine Variable mit dem Namen sehen? Weil die sehe ich nicht…

Die können das ‚erstmal‘ gar nicht.

Der Modus ist bei den Geräten leider noch ein Konfig Parameter und kein Datenpunkt. Somit auch keine Variable in Symcon.
Es gibt irgendwo im Forum Scripte für die HMXML (XMLRPC) damit geht es dann.
z.B. hier:

Habe die aber selber nicht mehr im Einsatz.

Michael