Hat hier wer eine Wolf ism8?

noch besser,

  • Variablen die in der Datapoint-Liste stehen und den namen „Unbekannt“ haben werden nicht mehr erstellt (muss getestet werden, tritt bei mir ncht auf, weil ich Firmware 1.5 habe)
  • Hin und wieder kam in den Meldungen „cannot auto-convert“. Die Störmeldevariablen haben schonmal keinen Wert übertragen (behoben)

Du kannst nach dem Update ein rechtsklick auf die Instanz machen, dort auf „Befehle Testen“ und „ISM_CreateVariableProfileManu“ ausführen. Das erstellt zum einen alle Profile manuell zum anderen gibt es Warnungen und Meldungen aus. Teste das mal bitte.

Eine Beta ist noch nicht erstellt. Nur über Github zu laden

Hallo kris,

habe das Modul aus dem Store deinstalliert und dann per github installiert.
Für den zweiten Punkt kann ich den Befehl „ISM_CreateVar…“ nicht ausführen, siehe auch Screenshot:
image
Allerdings wurden jetzt alle Variablen angelegt mit echten Werten.

Da ich die FW1.8 habe sage mir gerne kurz Bescheid kann auch gerne mehr testen.
Viele Grüße

Hi,
anbei noch ein paar Fehler die aktuell erzeugt werden.


Und der Debug
dump.txt (30,9 KB)

da stimmt was nicht. Das ist nicht die neuste Version des Moduls. Bist du sicher das die Version aus dem Store deinstalliert ist?

ggf mal alles deinstallieren, symcon neustarten und dann nochmal installieren. Eben weil das CreateVariableProfileManu() fehlt und zweitens, habe ich im Debug einige dinge geändert und das schon länger. Das fehlt auch.

Hi, jetzt habe ich das nochmal mit SymBox neustarten installiert, ich glaube mein Fehler war als ich gefragt wurde ob das aus dem ModulStore installiert werden soll :slight_smile:


Jetzt ist auch der Befehl da.
image
Ich hänge auch gleich einen Debug mit dran.
dump.txt (31,9 KB)
Dann kannst du gleich sehen ob ich das richtig gemacht habe.

Viele Grüße
Dominik

@kris hilft dir das weiter?

Viele Grüße

Muss ich mir später anschauen, bin unterwegs :+1:

@kris habe heute noch ein paar Fehler gehabt und stelle Dir das mal zur Verfügung.


Und den Dump.txt dazu.

Viele Grüße
Dominik
dump.txt (31,9 KB)

@kris hattest du schon eine Chance Dir das anzuschauen, oder hast du einen Tip wie ich die Fehler reduzieren kann :slight_smile:

Vielen dank und Gruß
Dominik

Leider noch nicht. Bin berufsbedingt gerade in den staaten und irgendwie fällt gerade Arbeit vom himmel :crazy_face:

Ich hoffe das ich nächste woche zeit finde.

Hi,

so, bin aus den USA zurück und der Jetlag soweit weggeschlafen…

Der Dump und die Meldung driften Zeitlich weit auseinander, keine Ahnung warum.

Aber so wie das aussieht, gibt es einen Datenpunkt den das Modul nicht kennt, dafür wird eine Meldung ins debug geschrieben.

Blöderweise bin ich hin gegangen und möchte die ID des Datenpunktes auch ins Debug schreiben. Das gibt es aber nicht :crazy_face:

Neue Version geht gleich online.

Viele Grüße

Hi,
super vielen Dank für deine Umsetzung. Habe es upgedated und beobachte es mal morgen.
Mir ist noch aufgefallen, das einige Variablen nie geändert werden, aber eigentlich sollten diese sich verändern.


z.B. der Status E-Heizung, die war definitiv an, aber irgendwie wurde das nicht angezeigt. Und bei mir verändern sich viele Variablen mit Erkennung_leer allerdings habe ich da bei Wolf keine Bschreibung gefunden was das für Datenpunkte sind, da wollte ich mal anrufen und nachfragen ob es mittlerweile dazu eine Beschreibung gibt :slight_smile:
Kann ich Dir sonst noch Informationen geben um das Modul noch zu verfeinern?`
Zu meiner Anlage ich habe eine Gas-Hybrid-Anlage Gasbrenner CGB-2 (mit AM Bedienmodul) eine BWL-1-S 10kw mit eingebauter 9KW Heizung (inkl. Kühlung) und das BM2 als Bedienmodul und das MM2 zur Steuerung der Micherkreispumpe.
Viele Grüße
Dominik

Hi,

alle Daten für die 1.8 wurden mir zur verfügung gestellt, prüfen kann ich Sie leider nicht. Aber du könntest folgendes machen:

In der Konsole gehst Du auf I/O Instanzen und doppelklickst auf „ISM8 Server Socket“, dort auf Debug.

Nun öffnest Du die Wolf Instanz und klickst auf „Daten neu Laden“. Nun warte mal 5 minuten und schicke mir den Dump aus der debug des „ISM8 Server Socket“ zu. Dann kann ich prüfen ob überhaupt was ankommt.

Und bei mir verändern sich viele Variablen mit Erkennung_leer allerdings habe ich da bei Wolf keine Bschreibung gefunden was das für Datenpunkte sind

Die kannst du löschen, diese sollten auch nicht mehr neu angelegt werden (hatte ich vor ein oder zwei Versionen rausgefiltert), ich lösche aber generell aus meinen Modulen keine Variablen…

Wenn Du mehr Infos von Wolf bekommst wäre das Super. Ich glaube ich stehe bei denen auf einer Blacklist. Außer „geht nicht“, kommt nur noch „gibts nicht“…

Viele Grüße