Dimmen im WebFront

Hallo,

kann mir bitte jemand helfen, wie man im WebFront einen Slider darstellt und die KNX-GA’s verknüpft um z.B. eine Lampe ein/auszuschalten und zu dimmen.

Ich habe 5 Gruppenadressen:

0/0/10 Licht EIN/AUS
0/0/11 Licht dimmen
0/0/12 Rückmeldung Helligkeitswert
0/0/13 Helligkeit setzen
0/0/14 Licht EIN/AUS Status

Ein/Aus ist ja kein Problem, aber das Dimmen…

Danke und Gruß
Wolfgang

Hast du denn auch korrekt ein 8-Bit Dimmerwert auf der GA anliegen? Wenn du die „normalen“ 3-Bit DimControl GAs nutzt, dann kannst du damit in IPS leider nichts anfangen.

paresy

Hallo Wolfgang,

die 0/0/13 scheint deine GA für Absolutwert (Prozent) zu sein. Die wird für den Slider benutzt, denn wie paresy bereits schrieb: relativ dimmen versteht IPS nicht.
Wenn der Dimmer neben dem Status EIN/AUS auch eine Rückmeldung in Prozent hat, dann verknüpfe diese zusätzlich als hörende Adresse (Knopf „Mehr“). Damit bekommt der Slider immer die aktuellen Werte vom Aktor, egal mit welchem KO geschaltet oder gedimmt wurde.

Vielleicht helfen diese Screenshots, wie es bei mir eingebunden ist:

dim1.1.PNG

dim2.PNG

Viel Erfolg,
Volker

@paresy, volkerm

ich habe es jetzt mal genauso hinterlegt. Jetzt ist auch ein Slider da. Nur passieren tut nichts.

Nachdem ich mal gelernt habe, daß man zur Übergabe von Werten in KNX ein Script braucht, habe ich folgendes als Aktionsscript angehängt. Macht aber trotzdem nichts …

EIB_DimValue(IPS_GetParent($_IPS['VARIABLE']), $_IPS['VALUE']);

die beiden GA sind 1Byte.

Bei den Meldungen erscheint der Wert aber …

16.12.2017 17:43:23*| VariableManager*| [OG\OG Licht \OG Bad Licht Allgemein dimmen\Wert] = 73

Script ist in diesem Fall nicht nötig, weil die EIB-Instanz sich darum kümmert.
Du musst nur ein KNX Device anlegen, GA eintragen, Funktion auf EIS6 DimValue einstellen und damit läuft es schon.

Siehst du im Gruppenmonitor der ETS die entsprechende GA auf dem Bus?

komisch, jetzt gehts.

Vielen Dank!!
Gruß Wolfgang:)

noch ne Frage …

Script ist in diesem Fall nicht nötig, weil die EIB-Instanz sich darum kümmert.

In welchen Fällen ist den jetzt tatsächlich ein Script nötig?

Ich denke, daß es immer dann nötig ist, wenn du eigene Variable anlegst.

Im Fall der EIB-Instanz wird diese eine Variable (hier: Dimmwert) automatisch erzeugt und ihr Verhalten (Wert senden zum / empfangen vom Bus) ist dann bereits vordefiniert.

ok, das ist nachvollziehbar.
Danke!
Gruß Wolfgang

Bitte löschen.

Du musst mit der ETS eine neue GA für die 8-Bit Werte anlegen - oder eben deine Elektriker fragen, dass er das vorbereitet :slight_smile:

paresy

Guten Tag Zusammen!

Ich habe am Wochenende meinen MDT Dimmer in Betrieb genommen und es funktioniert eigentlich auch so weit gut.

Ich kann mit der Taste EIN/AUS (Webfront) das Licht einschalten (Dimmwert springt auf Memory Funktion), dann kann ich mit dem SLIDER (Webfront) den Dimmwert verändern.

Bewege ich aber den SLIDER auf 0% geht das Licht aus, aber der EIN/AUS Schalter (Webfront) bleibt auf EIN.

Das Gleiche passiert umgekehrt, wenn der EIN/AUS Schalter/Button auf AUS geschalten wird, bleibt der Dimmwert am SLIDER auf z.B. 45%.

Die EIN/AUS Schalten GA ist mit der Rückmelde GA von EIN/AUS (MDT Dimmaktor Status) und dem Rückmeldeobjekt (% Dimmwert MDT) „MEHR“ verknüpft.

Wo liegt denn der Fehler?
Zumindestens wäre es Cool wenn bei SLIDER auf 0% (das Licht geht aus) auch er EIN/AUS Knopf im Webfront auf AUS gehen würde.

Danke und lg
Christian

Hast du die Beta-Version installiert? Leider ist in der aktuellen Stable Version ein Fehler mit den Rückmelde-GAs drin, welche in der webbasierten Konsole eingefügt werden.

paresy

Hi paresi,
ja habe ich…

Danke für die Info und lg

Abend, wo sehe ich denn wann der Bug behoben wurde?
Lg

Am einfachsten im Changelog schauen. Der Bug mit den GAs ist in der Beta auf jeden Fall gelöst.

paresy

Hi zusammen,

ich hab mal eine Frage. Denke das passt hier in den Thread.

Könnt ihr mir sagen welcher DPT in ETS eingestellt sein muss, damit man in Symcon direkt „EIS6 | DimValue 0-100%“ erhält?.

Oder geht das einfach nicht?


PastedGraphic-3.png

LG Olli

Es müsste irgendwas bei DPT 3.x sein (Der Export bei der ETS ist an der Stelle glaube ich etwas kaputt, da er es auf EIS2 mit 8Bit mappt… was wir dann korrekt als EIS6 setzen)

Du willst folgendes im OPC Export sehen: EIS 2 ‚Dimming - value‘ (8 Bit)

paresy

Hi paresy,

der Ausgang in meinem Fall (DALI Gateway Plus) bietet mit nur einen 1 byte Wert und ich kann gar kein DPT 3 auswählen. Es fängt bei 4.XXX an im ETS.

LG