Client Socket – Waiting for connect timed out

I use a client socket connection to monitor my solar panels. After moving IP-Symcon from a Windows 10 client to a fresh installed Windows Server 2019 system it is no longer possible to make a connection with my SolarEdge SE17K invertor.

A few seconds after activating the client socket connection the “Waiting for connect timed out.” appears.

This connection has worked without any problem on Windows 10. Other Client Socket connections with Raspberry Pi’s are working fine on Windows Server.

IP-Symcon V5,0, kernel date 16-12-2018
Windows Server 2019, latest updates

IP-Symcon - SolarEdge - Wating for connet timed out.PNG

Hello Henk,

what is with your firewall? Have you checked the settings?
Or you can turn off the firewall for a test?


The Windows firewall is off. I get replies on the ping command.

IP-Symcon logfile
02/04/19 20:35:38 | 22852 | ERROR | Event Control | Reconnecting [SolarEdge Modbus new] failed = Waiting for connect timed out

Windows Application eventlog, Source: PHP-7.2.9
PHP Warning: PHP Startup: Unable to load dynamic library ‚php_pdo_oci.dll‘
C:\IP-Symcon\ext\php_php_pdo_oci.dll.dll (The specified module could not be found.)) (C:\IP-Symcon\ips.exe)

There seems to be a public Firewall enabled. Can you disable it just to be sure? This problem sounds like a firewall problem.


Problem is the same after changing the Public profile for the firewall.

Can you put the device into the 192.168.1.x subnet and try again?


Reconfiguring the IP configuration of the SolarEdge invertor is time consuming.

Instead I replaced the new Windows Sever 2019 system with the old Windows 10 client, communication established!

I can ping the SolarEdge invertor from the Windows Server 2019 system, therefore I assume that the network configuration is not the problem.

I there a way to get some debug information of the communication problem in IP-Symcon?

Unfortunately there is no more debug information available.


Today I tested IP-Symcon 5.1 on Windows Server 2019, the communication problem still exists.

I used Wireshark to compare the communication between the SolarEdge inverter and IP-Symcon on Windows 10 and Windows Server 2019.
The intial packet sent after Activating the socket in IP-Symcon differs.

  • Windows 10 initiates the communication with the Flag [SYN], SolarEdge answers with [SYN ACK]
  • Windows Server 2019 initiates the communication with flags [SYN, ECN, CWR], SolarEdge answers with [RST]

Why does Windows Server uses the flags ECN and CWR?

The communication with the SolarEdge invertor works after disabling ECN!
netsh interface tcp set global ecncapability=disabled

I found the solution in the following article
Explicit Congestion Notification (ECN) slows down outbound connections - Sysadmins of the North

Windows Server 2012 and above have ECN turned on by default, on Windows clients ECN is off by default.

Thanks for posting your findings and the solution!