Azzurro Wechselrichter anbinden an IPS

Hallo,

könnt Ihr mir bitte mit nem Tipp weiterhelfen wie ich weiter machen könnte um
den Wechselrichter ins IPS zu bekommen?

Der Wechselrichter ist bereits mit Wlan im Netzwerk, ist auch mit dem Server des
Herstellers verbunden und zeigt mir auch Daten in der App dafür.
Würde es gern natürlich lokal benutzen.
In den Konfiguration kann ich noch einen Server eintragen, nur bin ich jetzt kein Experte.

Hoffe Ihr könnt mit nen Schubser in die richtige Richtung geben.

Danke schon mal Dafür.

Gruß

Sind recht wenige Informationen um einen GUTEN Tip geben zu können. So wie ich das gesehen habe ist das RS-485 Protokoll proprietär.
Beim WLAN könntest du versuchen im Symcon einen Server-Socket zu erstellen und dann den Wechselrichter auf die IP deines Symcon-Servers zu verweisen und dann im Debug schauen, ob Daten ankommen.

Grüße
Stefan

Hallo,

danke für den Tipp den probiere ich mal morgen aus. Wenn ich natürlich das schaffen sollte.
Morgen kommt auch ein neuer Zähler rein, mall was da so geht…

Hatte mal Support angeschrieben gehabt deswegen. Diese Meinten das tcp geht noch nicht.
rtu sollte aber schon. Habe die dann nach Registern gefragt, bis jetzt keine Antwort erhalten.
Habe über Linux herausgefunden das der Port 8899 frei ist und IPS Modbus-Gateway verbindet sich.

Weiter bin ich leider nicht gekommen.

In dem Stick kann ich noch einen Remote Server eintragen, vielleicht wäre das die Lösung,
kannte bis jetzt die Möglichkeit nicht. Muss erst schauen wie es geht.

Danke noch mal.

Gruß

Hallo,

leider brachte Server Socket nichts, wenn ich da auf Debug gehe kommt nichts.
Hoffe mache es auch richtig.

Ist das Normal das in Objektbaum Server Socket die IP 0.0.0.0:1053 hat?

Danke

Gruß

Mit der IP ist normal. Zumindest ist das bei mir auch so.

Die IP ist ok der Server Socket lauscht auf allen IP-Adressen deines Symcon-Servers.
Der Port muss natürlich zu deinem Client passen (Wechselrichter). Und im Wechselrichter musst du eben dein Symcon als Server angeben.

Danke euch.

Ja genau das machte ich auch, die IP der Symcon und den Port 1053.
TCP ist immer automatisch ausgewählt. UDP könnte ich nicht einstellen, springt immer zurück.

Weiß ja nicht ob der Aufwand sich lohnt, da die oder nur ein Zähler
würde ich auslesen. Ist ja quasi fast das selbe an Daten ist, außer
natürlich zusätzlich noch der Bezug…!
Bin noch am suchen wie das gehen sollte.

Gruß und danke euch noch mal

Hallo,

habe jetzt mal weiter geschaut. Bei ModBus Gataway schaute
ich nie im Debug Protokoll nach…

Da wird alle 5 Sec ein Transmit gemacht mit: 7E 03 9C 41 00 01 F1 81
also immer das gleiche.

Alle 2 Minuten kommt aber ein Wert mit 14 Länge rein, der ist immer anders…

A5 01 00 10 47 60 06 71 67 A4 65 00 9F 15

A5 01 00 10 47 60 07 71 67 A4 65 00 A0 15

A5 01 00 10 47 61 09 71 67 A4 65 00 A3 15

Was sagt Ihr dazu? Kann man damit was anfangen?

Dankeschön